(Close Window)
Topic: Error message when I hit "Submit"
Message: Posted by: Victor Brisbin (Oct 22, 2002 01:30AM)
Hi Mary: Since yesterday, each time I submit a reply, a PM, or an edit, I get a windows notice of "server not found." When I clicked the link to "detect the server," I get the following message: "Error doing DB query to get userid's from message." Is it my settings, a fluke, or something that I can correct?
Thanks! Vic
Message: Posted by: Mary B. (Oct 22, 2002 08:37AM)
Hmm... The error message you get is only contained in the routine for querying the private messages part of the database to obtain the "to" and "from" user id's for a particular private message. You shouldn't get that from submitting a reply to a post or editing a post, in any case.

Since this seems to be only happening to you, I would have to say it has something to do with either your settings, or possibly your internet connection at the time you got the error. If it were a problem with the scripts or the database, everyone would be experiencing the problem.

The "server not found" leads me to believe that maybe your internet connection was shaky yesterday. Ours does that sometimes, where we'll lose the connection for brief periods throughout the day. If it happens again, you might check into that.

Let me know if it continues to happen, I'll see what I can find out.
Message: Posted by: AllThumbs (Oct 22, 2002 07:18PM)

I am having the same problem. It has only appeared over the past couple of days and only with Private Messages.

Certain actions seem to cause this to happen, but its probably my imagination.


Kris Sheglova
Message: Posted by: x-treem (Oct 23, 2002 02:21AM)
I have had it twice today in the "edit post," though the error page did come up, my edit did appear.

When I wandered back in the front door.

It also happened when I sent a PM, to Mr. Guinn tonight, I can only assume he got it.

[b]<Addition>[/b] After posting a reply I clicked on the "Click here to view your message" It dropped me half way between the message and the Reply to post area rather than to the message. Not that it is a big deal, just wanted to let you know. [b]</Addition>[/b]
Message: Posted by: Steve Brooks (Oct 23, 2002 03:34AM)
I too am experiencing a number of error messages, and have contacted Mary. Rest assured she will find the source of these problems. ;)
Message: Posted by: x-treem (Oct 23, 2002 03:42AM)
Thanks Steve, I have a new one. I went to delete a PM and got "That's not your message you can't delete it"

Though humorous it was a PM to me.
Message: Posted by: Dave Scribner (Oct 23, 2002 06:15AM)
Just to add to the fun, I tried to edit a post and got a message saying "you can only edit your own post" What's a grammar host to do? I'm sure Mary will fix the problems.

Message: Posted by: Mary B. (Oct 23, 2002 01:57PM)
I'm going to ask Gene to look into this - he's more experienced than I am at this sort of thing. The odd thing is, it doesn't seem to be happening to everyone. That pretty much eliminates the scripts themselves as the source of the problem.

With all the member information, posts, and private messages, the database is (as I write this) 78.8 MB in size. That is a lot of information to sort through, and every time you access a page of the Café, almost all that information has to be searched before the page can be generated. That may or may not be the source of the problems you guys are having.
Message: Posted by: Gene (Oct 23, 2002 09:51PM)
The source of the problems reported here is unknown. None of the scripts associated with these problems have been changed in a long, long time, and the server appears to be functioning just fine. I cannot explain why these things are happening, nor why they have just started happening - it's a mystery to me. I have tried without success to duplicate any of these errors myself.

If you encounter the same error you reported here, please do the following and send your results to either Mary B. or me in a PM:

1. Bring up a neutral site (non-cafe page) in your browser.
2. Clear your browser's cache, then close your browser.
3. Bring up your browser and try to duplicate the problem again.
4. Report [b]exactly[/b] the details of how you were able to reproduce the error: which specific topic, what you were doing (replying, editing, etc.), and any other information that may be helpful.

The important thing to note is that we (Mary and I) need to be able to reproduce the problem before we can begin to determine why it's happening.

Some of this can be a combined symptom of network sluggishness and cache. If you get a "page not found" error on a certain page due to an internet network problem, that error could be saved to your cache. On the next view of that page you could very well see the cached error page again. That happens to me - it happens to everybody.

With respect to not being able to edit messages (especially the Moderators and Grammar Hosts), I have been unable to duplicate that as well.

"Error doing DB query to get userid's from message". This error is received when clicking the "detect server" link - and that's about right. You may notice there are some variables included in many of the Café's URLs. If any of those variables are missing, DB errors will result. This is normal. The "detect server" link on a "page not found" error doesn't function as you would expect it to with dynamic pages. That link can't set variables, so it can't do anything but give you an error.

There was a report recently about a DOS attack, but I don't know if that had anything to do with this.
Message: Posted by: sethbek (Oct 24, 2002 02:11PM)
Im still getting a "website not found" when I try to pm or do a site search.
:pepper: :spinningcoin: :pepper:
Message: Posted by: Gene (Oct 24, 2002 02:30PM)
I just tried repeatedly and was able to do both without error every time. Did you clear your cache? Did you follow the other procedures? Were you able to do it twice in a row?
Message: Posted by: Chris A. (Oct 25, 2002 03:38PM)
I had the same exact problems and fixed them thusly.

I checked in my cookie folders and saw that the Café had left like 20-30 cookies!

Logged out of the Café, deleted all Café related cookies, then logged back on.

Now everything works just peachy.
Message: Posted by: Gene (Oct 25, 2002 05:42PM)
Cookies? Hmm ...
Message: Posted by: Chris A. (Oct 26, 2002 01:52AM)
On 2002-10-25 18:42, Gene wrote:
Cookies? Hmm ...
[/quote]Very common fix for phpBB. And perhaps some of your hacks/mods are causing extra cookies to be set. Dunno for sure. But I literally had 20-30 Magic Café cookies lounging around in my cookies folder.
Message: Posted by: Masimax (Oct 28, 2002 02:20AM)
I've the same problem.
when I write my USERNAME and PASSWORD the answer is:

web site not found.

The same thing when I submit a REPLY, but the reply is accepted.
Message: Posted by: kusoyon (Oct 31, 2002 04:47PM)
I have had some log on problems myself! This is the 1st time I been on for about a week.
The situation is that I can't log into the "Magic Café." No matter if I use my old password or the new one they sent me it does not function. The results is the following:
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.


Please try the following:

Click the Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).
If your Network Administrator has enabled it, Microsoft Windows can examine your network and automatically discover network connection settings.
If you would like Windows to try and discover them,
click Detect Network Settings
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.
If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.
Click the Back button to try another link.

I tried to contact Steve on this matter/issue but he does not respond back to me. I hope you can assist me, my friends.
Frank Thomas