(Close Window)
Topic: Electric Touch Help
Message: Posted by: Kune (Nov 28, 2008 07:21AM)
I just go an Electric Touch off ebay, and I think it may be defective, but I haven't used one before, so I wanted to ask here to make sure I'm doing it all correctly.

1. What normally happens when you activate it, but don't have it at all grounded? Mine makes a loud hissing noise, and after a few seconds a stream of sparks starts flying out of the end metal bit (I'm too scared to see what happens if you wait more than a few seconds. Also if you're too close to it, it gives you a bad shock.

2. How much power can people generally get on high? I tried with it on carpet and concrete for moving tiny pieces of paper, salt, pepper, and lighting up a florescent lightbulb (with shoes on and standing on some cardboard). The pieces of paper would cling to my hand slightly if I touched them, and the others didn't work at all. Maybe I just don't have it grounded enough?

3. The low setting doesn't seem to work at all - no light, sound, or zapping.


What's everyones opinion, do I just need to get better grounding, and find a way to repair the low setting, or is it a fault unit and likely to stop working entirely soon? Thanks! :)


And I guess I may as well ask at the same time - if anyone could email me the P.E.T.S. set-up I keep hearing about, that would be excellent! Thanks again.
Message: Posted by: Kune (Nov 30, 2008 10:36AM)
After trying it out some more I've decided to change my questions:

1. Does anyone know how I can fix my low power setting (at the moment it only works on high).

2. Can anyone send me the P.E.T.S setup info? (the forum you're supposed to get it from is down and looks like it won't be back up any time soon :( ).
Message: Posted by: Frank Russell (Dec 1, 2008 10:55PM)
It sounds like you have a defective unit. Mesika will repair it for you. You just have to send it in to them. As for P.E.T.S. Good luck finding it. Ever since the secret site was hacked into, the secret vanished too. I have been trying to get someone to help me with it but no reply. Not even Phillippe (not sure if the spelling is right)
Message: Posted by: Philippe (Dec 2, 2008 03:19AM)
I have PM'd you Kune & Frank
Philippe
Message: Posted by: Kune (Dec 2, 2008 10:27AM)
Thanks Philippe thanks Frank for the advice. Unfortunately I think the postage both ways would cost about as much as I paid for the unit, but I'll try sending Yigal an email in case he knows a way I can fix it myself.
Message: Posted by: adamshrum (Dec 13, 2008 10:11PM)
Can somebody please please pretty please e-mail or PM me the P.E.T.S setup info? I'd really appreciate it.
Message: Posted by: Justin Lewis (Dec 28, 2008 12:37PM)
Low setting? there should be a switch on the device. I don't think it would be smart to open the internal device