The Magic Café
Username:
Password:
[ Lost Password ]
  [ Forgot Username ]
The Magic Cafe Forum Index » » The Magic Café Tech Help Area » » I hate the search funtion.!!! » » TOPIC IS LOCKED (0 Likes) Printer Friendly Version

 Go to page 1~2 [Next]
Jordini
View Profile
Inner circle
2766 Posts

Profile of Jordini
The search function for me never ever ever works! Why is this? It doesn't even look/act like it's trying.
Dave Scribner
View Profile
Assistant Manager
Lake Hopatcong, NJ
5168 Posts

Profile of Dave Scribner
Jordini, the search function works fine. If you can give us an example of what you are trying to search for, we might be able to determine why you are having the problem.
Where the magic begins
Jordini
View Profile
Inner circle
2766 Posts

Profile of Jordini
Well, when I use the Café quicksearch, the screen goes to the "searching" window, but never gives me any results, it just stays on that "searching" screen. When I use advanced search, I get an error message that I need to type in a keyword or member name. The problem is, I already have typed in a key word, but yet, it's not registering.
Jaz
View Profile
Inner circle
NJ, U.S.
6112 Posts

Profile of Jaz
I've also had this happen to me.
Not constantly but it does happen.
Yesterday I typed "halloween" in Advanced search and got the same error message. Quick searches didn't find some common keywords.

Later I tried again and it was fine.
Dave Scribner
View Profile
Assistant Manager
Lake Hopatcong, NJ
5168 Posts

Profile of Dave Scribner
The quicksearch does take a little longer than the advanced search based on the number of inquiries and searches the data base is handling at any given time.

Jordini, can you give me some examples of words you've tried to search on? Remember, all the words have to be more that 3 letters in length.

Jazz, I tried searching on Halloween both with quicksearch and with the advanced. Quicksearch took almost 2 full minutes to retrieve while the advanced took 1 minute. In both cases, a total of 29 pages were displayed.
Where the magic begins
danielrhall
View Profile
Regular user
NH, where some days I feel as dumb as
181 Posts

Profile of danielrhall
Quote:
On 2004-09-28 15:43, Jordini wrote:
Well, when I use the Café quicksearch, the screen goes to the "searching" window, but never gives me any results, it just stays on that "searching" screen. When I use advanced search, I get an error message that I need to type in a keyword or member name. The problem is, I already have typed in a key word, but yet, it's not registering.


Same here. I nearly always use the Advanced search function. Quite often, I'll enter my search string and start the search, and the screen changes to the search screen ("You will be forwarded to the results in a moment"), but nothing happens. I know I'm wasting my time if I don't see a progress bar advancing at the bottom of the screen. So I bail out by clicking on "click HERE to return to the search form", I enter the search string again, and it always works the second time.

-Dan
Jordini
View Profile
Inner circle
2766 Posts

Profile of Jordini
I entered charming chinese challenge, and nothing came up, so I entered chinese challenge, and nothing came up, and I entered chinese and nothing came up.
Dave Scribner
View Profile
Assistant Manager
Lake Hopatcong, NJ
5168 Posts

Profile of Dave Scribner
This sounds like you are having trouble with your server. I did a search using your examples with the following results.

Charming chinese Chanllenge results in 35 seconds 6 pages

chinese challenge results in 65 seconds 7 pages

chinese results in 2 seconds 82 pages.

The speed is dependant on the number of members on line and the number of querries being submitted but I wouldn't say 35 to 65 seconds is bad for the most part.
Where the magic begins
Jordini
View Profile
Inner circle
2766 Posts

Profile of Jordini
I couldn't even get the search started though. Oh well. I found what I was looking for regardless.
presdough
View Profile

Jamestown, NY
0 Posts

Profile of presdough
When I searched for "jc wagner", it told me that my keyword needed to be a minimum of 3 letters. It also gave me the same result when I searched for "mentally by two". I did not use quotes in the search BTW.
Mary B.
View Profile
Café Tech Advisor
Howard City, Michigan
626 Posts

Profile of Mary B.
It's supposed to give you that error message when you put in keywords that are less than three characters.
Johnnymysto
View Profile
Regular user
South Carolina
116 Posts

Profile of Johnnymysto
Here is the problem: if you put in your search request and hit Enter, you will get the screen telling you it's searching, and that's all. It doesn't really search. But, if you click on "Go" instead, then it actually does the search. I think this has been a problem since its inception.

-Eric
Dave Scribner
View Profile
Assistant Manager
Lake Hopatcong, NJ
5168 Posts

Profile of Dave Scribner
Eric, thanks for the input however, both methods will retrieve the searched for data. I used the example Jordini gave with Charming Chinese and using the begin search and the enter key both returned the results in less a minute.
Where the magic begins
Beetroot
View Profile
Loyal user
267 Posts

Profile of Beetroot
Re: "I know I'm wasting my time if I don't see a progress bar advancing at the bottom of the screen."

I'm not an expert, but progress bars on web pages are probably harder to implement than on non-browser applications (or web pages that don't use plug-ins), especially where database queries are concerned so I wouldn't necessarily use this as an indicator that things aren't working.
Review King
View Profile
Eternal Order
14446 Posts

Profile of Review King
Lately I find it works great for me. it must have been improved in the upgrade.
"Of all words of tongue and pen,
the saddest are, "It might have been"

..........John Greenleaf Whittier
danielrhall
View Profile
Regular user
NH, where some days I feel as dumb as
181 Posts

Profile of danielrhall
Beetroot:

Thanks for the comment.

I'm far from an expert on progress bars and web pages. My evidence is purely anecdotal. When I don't see the progress bar (not just not advancing, but not there at all), waiting doesn't help, so I just start again.

-Dan
jalsing
View Profile
New user
Allen, TX
89 Posts

Profile of jalsing
I've noticed the progress bar issue as well. If I enter search criteria and IE shows a progress bar in the status toolbar, a result will appear. If no progress bar appears, it won't. This isn't an implementation of the forum or db query, but something to do with IE still waiting for data or it's received all the data it's gonna get.

Also, I've noticed as noted above, quicksearches are far more likely to succeed if I use the go button as opposed to pressing enter.

-Jason
Jordini
View Profile
Inner circle
2766 Posts

Profile of Jordini
Ok, so here's the deal. When I typed my key word into the search box (on the upper lefthand corner of the Café, right where the green box stops) and hit the "GO" button (NOT ENTER) but the "GO" button, everthing worked JUST fine. So that's the key, just hit the "GO" button and everything should work.
Gene
View Profile
Café Forum Developer
Howard City, MI
444 Posts

Profile of Gene
It's a browser issue. Not every browser handles everything the same way as others do. For example, the search function uses a "refresh" meta tag. Some browsers (including IE) can be set to ignore meta refreshes, and even if set sometimes do not read the meta anyway. So, depending on your browser and settings, search may or may not work when using the Quicksearch. For those having problems with Quicksearch, and more importantly, the main search page, bookmark this version:

http://themagiccafe.com/forums/search2.php

This one does not use the refresh meta. This is not the "final" answer, but it will help those having browser problems with the main search interface.
Somebody kick me off the computer, will ya? Smile Smile
caubeck
View Profile
Elite user
403 Posts

Profile of caubeck
Thanks Gene,

But I'm afraid this hasn't helped me very much. I have the same problem as the others, with the search engine working some 6 times out of ten for me. If there's anything else I can do please let me know!

I also think the minimum/restricted character search criteria is a pain, as abbreviations are so often used in the posts (S&S, C/S, etc). But the rest of the site is so well constructed I'm happy to live with it. Smile
The Magic Cafe Forum Index » » The Magic Café Tech Help Area » » I hate the search funtion.!!! » » TOPIC IS LOCKED (0 Likes)
 Go to page 1~2 [Next]
[ Top of Page ]
All content & postings Copyright © 2001-2021 Steve Brooks. All Rights Reserved.
This page was created in 0.13 seconds requiring 5 database queries.
The views and comments expressed on The Magic Café
are not necessarily those of The Magic Café, Steve Brooks, or Steve Brooks Magic.
> Privacy Statement <

ROTFL Billions and billions served! ROTFL